Powerdynamo MZB INSTALLATION ON A KX500

A closer look at your electrical system
User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: MZB INSTALLATION ON A KX500

Post by Sandblaster » Thu Aug 21, 2014 10:31 pm

Admittedly, it took me a few tries to get it right.
The first thing I noticed is that my crank stuck too far out into the flywheel hole :o
KX500 2001 MZB INSTALLATION 3-1.JPG
KX500 2001 MZB INSTALLATION 3-1.JPG (22.45 KiB) Viewed 2270 times
But, the kit came with 3 washers that were perfect for the job... Almost like they knew I would need them..
KX500 2001 MZB INSTALLATION 3-2.JPG
KX500 2001 MZB INSTALLATION 3-2.JPG (21.83 KiB) Viewed 2270 times
So I put the washers on then slipped the flywheel on with just a light smear of blue (Weak) retaining compound.
With the dial indicator at .087" reversed rotation from TDC I put the nut on just a few threads.
Then I took my Makita and ran the nut up on the flywheel fast to drive the flywheel on and set it in position.
Makita...
KX500 2001 MZB INSTALLATION 3-4.JPG
KX500 2001 MZB INSTALLATION 3-4.JPG (48.42 KiB) Viewed 2270 times
Because the flywheel moved when I did this (About .010") I had to figure something else out.
So, I read the directions :?
It says to use a block of wood to lightly tap the flywheel on and then set the nut.
I tried it by the directions and the flywheel moved again!
So after talking with Alward25 I tried another tactic...
KX500 2001 MZB INSTALLATION 2-4.JPG
KX500 2001 MZB INSTALLATION 2-4.JPG (27.68 KiB) Viewed 2270 times
Yes, I greased the face of the nut and one of the washers.
I got everything set and the drove the nut on again with my Makita.
Success!!!

By the way, the guy holding the parts is a professional hand model and is available for hire :lol:
If bikes are for kids I'll never grow up.

User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: MZB INSTALLATION ON A KX500

Post by Sandblaster » Thu Aug 21, 2014 10:56 pm

With the flywheel set, I rolled the engine completely over and made double sure that with the line on the flywheel and the dot on the stator lined up the indicator is still at .087"... Yep.... Poifect! (Spelling error intended) :geek:

The next thing I did was use some Black RTV Silicon around the stator wire where it is leaving the case.
I did the inside and the outside to be sure it is well sealed.
Now it is time to install all the other goodies.
I started with the coil.
I wanted to install it where the old coil went.
I looked at doing a bracket to mount it to and a few other ways.
Then I decided the easiest way to mount it was to slot the coil plate as shown..

[attachment=3]KX500 2001 MZB INSTALLATION 2-2.JPG[/attachment]

I did this on both sides.

[attachment=2]KX500 2001 MZB INSTALLATION 1-9.JPG[/attachment]

[attachment=1]KX500 2001 MZB INSTALLATION 2-1.JPG[/attachment]

I made the first slot and did a test fit.
With the first slot the coil just barely touched the gas tank.
I didn't like it so I made a new slot and tested it.
Beautiful.
If you use the 20mm and 27mm measurements to cut the slots it will mount just where you need it.
Mounted and looking good.

[attachment=0]KX500 2001 MZB INSTALLATION 3-3.JPG[/attachment]
Attachments
KX500 2001 MZB INSTALLATION 3-3.JPG
KX500 2001 MZB INSTALLATION 3-3.JPG (72.16 KiB) Viewed 2270 times
KX500 2001 MZB INSTALLATION 2-1.JPG
KX500 2001 MZB INSTALLATION 2-1.JPG (33.36 KiB) Viewed 2270 times
KX500 2001 MZB INSTALLATION 1-9.JPG
KX500 2001 MZB INSTALLATION 1-9.JPG (42.79 KiB) Viewed 2270 times
KX500 2001 MZB INSTALLATION 2-2.JPG
KX500 2001 MZB INSTALLATION 2-2.JPG (45.44 KiB) Viewed 2270 times
If bikes are for kids I'll never grow up.

User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: MZB INSTALLATION ON A KX500

Post by Sandblaster » Fri Aug 22, 2014 3:12 am

If you take a good look at the last pic, you will see a HUGE ground wire on the lower right side.
I do not like grounding issues so all the grounds on the system all go to the same place.
If bikes are for kids I'll never grow up.

User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: MZB INSTALLATION ON A KX500

Post by Sandblaster » Tue Aug 26, 2014 2:41 am

The new style regulator mounts where the old CDI went.
KX500 2001 MZB INSTALLATION 2-3.JPG
KX500 2001 MZB INSTALLATION 2-3.JPG (56.28 KiB) Viewed 2266 times
It's held on with one bolt at the top.
Seems to be enough but may have to add another..

Put the stator cover on and we are ready to run the wires.
KX500 2001 MZB INSTALLATION 2-5.JPG
KX500 2001 MZB INSTALLATION 2-5.JPG (52.62 KiB) Viewed 2266 times
If bikes are for kids I'll never grow up.

User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: MZB INSTALLATION ON A KX500

Post by Sandblaster » Tue Aug 26, 2014 2:52 am

Wire it up....
The only thing that seemed a little wiggy on the directions was there was two black wires on the CDI/COIL and two from the Stator that are suppose to hook to one another.... but which went where? it didn't make squat for difference.
All the grounds went to the same place on the coil mounting bolt and plate.
Drum roll!!!

Started it right up.
Put the volt meter to the battery at idle, 13.4 volts.

Ok, time for a ride.
If bikes are for kids I'll never grow up.

User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: MZB INSTALLATION ON A KX500

Post by Sandblaster » Tue Aug 26, 2014 3:02 am

Idles a little smoother... It was pretty smooth before...
Take it for a couple of laps around the block to get the water temp up.... (My bike runs cool)
Finally got it warmed up and wicked on the throttle.
With a flywheel that is 1 lb lighter then stock, it revs up quicker and smoother then ever before.
The really cool thing is MY LIGHTS WORK AWESOME!!!
No more having to charge the battery every 45 minutes of ride time.

So far, I'm smiling.

Total installation time?
It took me 6 hours.
It could be done a lot faster if your competent which I'm not.
That being said I could do another much faster the second time around :ugeek:
If bikes are for kids I'll never grow up.

D Bergstrom
Posts: 9
Joined: Mon Apr 10, 2017 12:38 am

Re: Powerdynamo MZB INSTALLATION ON A KX500

Post by D Bergstrom » Sun Jun 04, 2017 4:48 pm

Are you still running this ignition? If so, how is it holding up? Since my 500 is now 17 years old, i was thinking about buying all new electronics for it and keep my existing stuff as spares. (Who knows how long until these items are discontinued.) After looking, looks like it will cost me $650 for a stator, coil, and igniter. I see you can get a Powerdynamo ignition for $500, and I get to run lights, sounds like a much better option! Just wanted to see if you have had any problems.Also, best place to buy one? i see them list on eBay, any better options?

Thanks,

Doug

User avatar
Sandblaster
Posts: 5715
Joined: Thu Jun 07, 2012 3:50 pm
Location: Eugene, OR
Contact:

Re: Powerdynamo MZB INSTALLATION ON A KX500

Post by Sandblaster » Mon Jun 05, 2017 3:04 am

Hi Doug.
I'm getting ready to install my third one (All different bikes) So that means I love it!
The best place to get one is from Alex Ward.
I believe they are around 400..
208-249-7152
If bikes are for kids I'll never grow up.

D Bergstrom
Posts: 9
Joined: Mon Apr 10, 2017 12:38 am

Re: Powerdynamo MZB INSTALLATION ON A KX500

Post by D Bergstrom » Fri Jun 09, 2017 3:27 pm

Thanks for the info, will for sure be picking one up. Will give Alex a call here in a few weeks once I am ready.

Thanks again,

Doug

Post Reply

Return to “Electrical”

Who is online

Users browsing this forum: No registered users and 1 guest